Arbitrary Code Injection Affecting jekyll package, versions <1.0.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUBY-JEKYLL-20382
  • published5 Jul 2017
  • disclosed23 Jan 2013
  • creditBen Toews

Introduced: 23 Jan 2013

CVE NOT AVAILABLE CWE-95  (opens in a new tab)

How to fix?

Upgrade jekyll to version 1.0.0 or higher.

Overview

jekyll is a simple, blog aware, static site generator.

Affected versions of the package are vulnerable to Arbitrary Code Injection. An attacker may be able to craft a malicious yaml file that would cause the parsing server to run arbitrary ruby code.

CVSS Base Scores

version 3.1