Remote Code Execution (RCE) Affecting mini_magick package, versions <4.9.4


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
7.64% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUBY-MINIMAGICK-451567
  • published12 Jul 2019
  • disclosed12 Jul 2019
  • creditJanko Marohnic

Introduced: 12 Jul 2019

CVE-2019-13574  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade mini_magick to version 4.9.4 or higher.

Overview

mini_magick is a ruby wrapper for ImageMagick or GraphicsMagick command line.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). A fetched remote image filename can cause remote command execution due to Image.open input being directly passed to Kernel#open, which accepts a | character followed by a command.

CVSS Base Scores

version 3.1