Incorrect Permissions Affecting netaddr package, versions <1.5.3>=2.0, <2.0.4


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
2.35% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUBY-NETADDR-472456
  • published9 Oct 2019
  • disclosed9 Oct 2019
  • creditUnknown

Introduced: 9 Oct 2019

CVE-2019-17383  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade netaddr to version 1.5.3, 2.0.4 or higher.

Overview

netaddr is a gem for performing calculations on IPv4 and IPv6 subnets.

Affected versions of this package are vulnerable to Incorrect Permissions. It has misconfigured file permissions, which impacts the target filesystem by giving it 777 permissions (read/write/execute) for all owner types (owner/group/others) when installing the gem.

References

CVSS Base Scores

version 3.1