Insecure Permissions Affecting octokit package, versions >=4.23.0, <4.25.0


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-OCTOKIT-2928761
  • published 22 Aug 2022
  • disclosed 16 Jun 2022
  • credit nickfloyd

How to fix?

Upgrade octokit to version 4.25.0 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Permissions due to the gem file containing world-writeable files. This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem.

Workaround:

Users that can't upgrade to version 4.25.0 can revert to version 4.22.0. Alternatively, users can modify the file permissions manually.