Insecure Permissions Affecting octopoller package, versions >=0.2.0, <0.3.0


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-OCTOPOLLER-2928759

  • published

    16 Jun 2022

  • disclosed

    16 Jun 2022

  • credit

    nickfloyd

How to fix?

Upgrade octopoller to version 0.3.0 or higher.

Overview

octopoller is a micro gem for polling and retrying, perfect for making repeating requests.

Affected versions of this package are vulnerable to Insecure Permissions due to the gem file containing world-writable files, this means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem.