Improper Authentication Affecting omniauth package, versions <1.9.2 >=2.0.0.pre.rc1, <2.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-OMNIAUTH-2987513
  • published 19 Aug 2022
  • disclosed 19 Aug 2022
  • credit Unknown

How to fix?

Upgrade omniauth to version 1.9.2, 2.0.0 or higher.

Overview

omniauth is a generalized Rack framework for multiple-provider authentication.

Affected versions of this package are vulnerable to Improper Authentication. It does not escape the message_key value.

References