Arbitrary Command Injection Affecting pdfkit package, versions < 0.5.3


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-PDFKIT-20071
  • published 20 Feb 2013
  • disclosed 20 Feb 2013
  • credit Unknown

Overview

PDFKit is a gem that uses wkhtmltopdf to create PDFs using HTML. Affected versions of PDFKit contain a flaw that is due to the program failing to properly validate input during the handling of parameters when generating PDF files. This may allow a remote attacker to potentially execute arbitrary code via the pdfkit generation options.