Access Restriction Bypass Affecting publify_core Open this link in a new tab package, versions >=9.0.0.pre1, <9.2.5


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-PUBLIFYCORE-1909502

  • published

    2 Nov 2021

  • disclosed

    2 Nov 2021

  • credit

    Unknown

How to fix?

Upgrade publify_core to version 9.2.5 or higher.

Overview

publify_core is a Core engine for the Publify blogging system, formerly known as Typo.

Affected versions of this package are vulnerable to Access Restriction Bypass due to front-end restrictions. Random users can self-register even when the admin does not allow it.