Improper Access Control Affecting publify_core Open this link in a new tab package, versions <9.2.9


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-PUBLIFYCORE-2841653

  • published

    24 May 2022

  • disclosed

    24 May 2022

  • credit

    Jonatas Fil

How to fix?

Upgrade publify_core to version 9.2.9 or higher.

Overview

publify_core is a Core engine for the Publify blogging system, formerly known as Typo.

Affected versions of this package are vulnerable to Improper Access Control where a low-privileged user can modify and delete admin articles by changing the value of the article[id] parameter.