HTTP Request Smuggling Affecting puma Open this link in a new tab package, versions <4.3.9 >=5.0.0, <5.5.1


0.0
low
  • Attack Complexity

    High

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-PUMA-1730572

  • published

    13 Oct 2021

  • disclosed

    12 Oct 2021

  • credit

    asta12, mattiasgrenfeldt

How to fix?

Upgrade puma to version 4.3.9, 5.5.1 or higher.

Overview

puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications. Puma is intended for use in both development and production environments. It's great for highly concurrent Ruby implementations such as Rubinius and JRuby as well as as providing process worker support to support CRuby well.

Affected versions of this package are vulnerable to HTTP Request Smuggling when using a proxy which forwards LF characters as line endings. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client.