HTTP Request Smuggling Affecting puma Open this link in a new tab package, versions <4.3.12 >=5.0.0, <5.6.4


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-PUMA-2437090

  • published

    31 Mar 2022

  • disclosed

    30 Mar 2022

  • credit

    Zhang Zeyu

How to fix?

Upgrade puma to version 4.3.12, 5.6.4 or higher.

Overview

puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications. Puma is intended for use in both development and production environments. It's great for highly concurrent Ruby implementations such as Rubinius and JRuby as well as as providing process worker support to support CRuby well.

Affected versions of this package are vulnerable to HTTP Request Smuggling via the front-end proxy, due to improper validation of the incoming HTTP request which should match the RFC7230 standard. This can lead to a disagreement on where a request starts and ends between Puma and the frontend proxy.

Note: When deploying a proxy in front of Puma, the user should turn on all functionality to make sure that the request matches the RFC7230 standard.