HTTP Request Smuggling Affecting puma package, versions <5.6.7 >=6.0.0, <6.3.1



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.13% (48th percentile)
Expand this section
9.8 critical
Expand this section
7.3 high
Expand this section
Red Hat
7.3 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-PUMA-5846204
  • published 19 Aug 2023
  • disclosed 18 Aug 2023
  • credit Unknown

How to fix?

Upgrade puma to version 5.6.7, 6.3.1 or higher.


puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications. Puma is intended for use in both development and production environments. It's great for highly concurrent Ruby implementations such as Rubinius and JRuby as well as as providing process worker support to support CRuby well.

Affected versions of this package are vulnerable to HTTP Request Smuggling when parsing chunked transfer encoding bodies and zero-length Content-Length headers in a way that allowed the exploitation of this vulnerability. The severity of this issue is highly dependent on the nature of the website using the library. This could be caused by incorrect parsing of trailing fields in chunked transfer encoding bodies or blank/zero-length Content-Length headers.