Information Disclosure Affecting puppet Open this link in a new tab package, versions <6.25.1 >=7.0.0, <7.12.1


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-PUPPET-1922237

  • published

    17 Nov 2021

  • disclosed

    9 Nov 2021

  • credit

    Unknown

How to fix?

Upgrade puppet to version 6.25.1, 7.12.1 or higher.

Overview

puppet is an automated configuration management tool.

Affected versions of this package are vulnerable to Information Disclosure that may result in a leak of HTTP credentials.