Authentication Bypass Affecting smart_proxy_dynflow package, versions >=0.1.8, <0.1.11>=0.2.0, <0.2.1


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
6.17% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUBY-SMARTPROXYDYNFLOW-72406
  • published26 Sept 2018
  • disclosed14 Sept 2018
  • creditUnknown

Introduced: 14 Sep 2018

CVE-2018-14643  (opens in a new tab)
CWE-592  (opens in a new tab)

How to fix?

Upgrade smart_proxy_dynflow to version 0.1.11, 0.2.1 or higher.

Overview

smart_proxy_dynflow is a plugin into Foreman's Smart Proxy for running Dynflow actions on the Smart Proxy.

Affected versions of this package are vulnerable to Authentication Bypass. A malicious user could use this flaw to remotely execute arbitrary commands on machines managed by vulnerable Foreman instances, in a highly privileged context.

CVSS Base Scores

version 3.1