Cross-site Request Forgery (CSRF) Affecting solidus_auth_devise package, versions >=3.1.0, <3.1.3 >=3.0.0, <3.0.3 >=2.6.0, <2.11.12 >=1.0.0, <2.5.4


0.0
critical

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
    Confidentiality High
    Integrity High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-SOLIDUSAUTHDEVISE-1922731
  • published 18 Nov 2021
  • disclosed 18 Nov 2021
  • credit vampire000

How to fix?

Upgrade solidus_auth_devise to version 3.1.3, 3.0.3, 2.11.12, 2.5.4 or higher.

Overview

solidus_auth_devise is a Provides authentication and authorization services for use with Solidus by using Devise and CanCan.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via solidus_auth_devise.

Note: Users are affected only if protect_from_forgery method is both:

  1. Executed whether as:

    a) A before_action callback (the default)

    b) A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find).

  2. Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception).

That means that applications that haven't been configured differently from what it's generated with Rails aren't affected.

References