Privilege Escalation Affecting solidus_backend package, versions <1.1.0.pre2


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SOLIDUSBACKEND-20472

  • published

    10 Jan 2018

  • disclosed

    6 Oct 2015

  • credit

    Andrew Thal

How to fix?

Upgrade solidus_backend to version 1.1.0.pre2 or higher.

Overview

solidus_backend is Admin interface for the Solidus e-commerce framework.

Affected versions of the package are vulnerable to Privilege Escalation. A lower-level admin can change the email address of a higher-level admin to an email address they have access to, and as a result they will gain access to the admin's permissions.