Cross-site Request Forgery (CSRF) Affecting solidus_backend package, versions <2.11.16 >=3.0.0, <3.0.6 >=3.1.0, <3.1.6


0.0
low
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SOLIDUSBACKEND-2850746

  • published

    2 Jun 2022

  • disclosed

    1 Jun 2022

  • credit

    Unknown

How to fix?

Upgrade solidus_backend to version 2.11.16, 3.0.6, 3.1.6 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) by allowing attackers to change the state of an order's adjustments if they hold its number, and the execution happens on a store administrator's computer.

References