Privilege Escalation Affecting solidus_core Open this link in a new tab package, versions <1.1.0.pre2


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SOLIDUSCORE-20474

  • published

    10 Jan 2018

  • disclosed

    6 Oct 2015

  • credit

    Andrew Thal

Introduced: 6 Oct 2015

CWE-264 Open this link in a new tab

How to fix?

Upgrade solidus_core to version 1.1.0.pre2 or higher.

Overview

solidus_core is Essential models, mailers, and classes for the Solidus e-commerce project.

Affected versions of the package are vulnerable to Privilege Escalation. A lower-level admin can change the email address of a higher-level admin to an email address they have access to, and as a result they will gain access to the admin's permissions.