Cross-site Request Forgery (CSRF) Affecting solidus_frontend Open this link in a new tab package, versions <2.11.14 >=3.0.0, <3.0.5 >=3.1.0, <3.1.5


0.0
low
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SOLIDUSFRONTEND-2322122

  • published

    21 Dec 2021

  • disclosed

    21 Dec 2021

  • credit

    Unknown

How to fix?

Upgrade solidus_frontend to version 2.11.14, 3.0.5, 3.1.5 or higher.

Overview

solidus_frontend is a cart and storefront for the Solidus e-commerce project.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Using a user's cookie, an attacker is able to add an item to the user's cart without authorization.