Improper Input Validation Affecting solidus_frontend package, versions >=2.8.0, <2.8.6 >=2.9.0, <2.9.6 >=2.10.0, <2.10.2

  • Exploit Maturity

    Proof of concept

  • Attack Complexity


  • Integrity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    5 Aug 2020

  • disclosed

    5 Aug 2020

  • credit

    Martin Meyerhoff, Alberto Vena

How to fix?

Upgrade solidus_frontend to version 2.8.6, 2.9.6, 2.10.2 or higher.


solidus_frontend is a cart and storefront for the Solidus e-commerce project.

Affected versions of this package are vulnerable to Improper Input Validation. It allows a malicious customer to craft request data with parameters that allow changing the address of the current order without changing the shipment costs associated with the new shipment. All stores with at least two shipping zones and different costs of shipment per zone are impacted.