Authorization Bypass Affecting sorcery package, versions >=0.8.3, <0.9.1


0.0
low

Snyk CVSS

    Attack Complexity High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-SORCERY-20425
  • published 7 Dec 2017
  • disclosed 4 Apr 2015
  • credit Grzegorz Witek

How to fix?

Upgrade sorcery to version 0.9.1 or higher.

Overview

sorcery Provides common authentication needs such as signing in/out, activating by email and resetting password.

Affected versions of the package are vulnerable to Authorization Bypass. The state field was kept between requests.

References