Authentication Bypass Affecting sorcery package, versions <0.15.0



    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.23% (62nd percentile)
Expand this section
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-SORCERY-568682
  • published 8 May 2020
  • disclosed 7 May 2020
  • credit Ortwin Gentz, FutureTap

How to fix?

Upgrade sorcery to version 0.15.0 or higher.


sorcery is a package that provides common authentication needs such as signing in/out, activating by email and resetting password.

Affected versions of this package are vulnerable to Authentication Bypass. There is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout.