Arbitrary Command Execution Affecting sounder Open this link in a new tab package, versions < 1.0.2


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SOUNDER-20106

  • published

    13 Aug 2013

  • disclosed

    13 Aug 2013

  • credit

    Unknown

Overview

Sounder plays sounds on macOS. Affected versions of this gem are vulnerable to arbitrary command execution by a context-dependent attacker due to mishandling of file names.