Malicious Package Affecting spider_src package, versions >=0.0.0


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    High

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPIDERSRC-566734

  • published

    17 Apr 2020

  • disclosed

    17 Apr 2020

  • credit

    Reversing Labs

How to fix?

Avoid using spider_src altogether.

Overview

spider_src is a malicious package.

Affected versions of this package were found to be a Malicious Package, as it utilised typosquatting to run Malicious 3rd party scripts. It replaced genuine packages using an _ and replaced it with - and vice versa

References