Information Exposure Affecting spree_api Open this link in a new tab package, versions >=3.7.0, <3.7.13 >=4.0.0, <4.0.5 >=4.1.0, <4.1.12


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREEAPI-1040422

  • published

    15 Nov 2020

  • disclosed

    13 Nov 2020

  • credit

    Unknown

How to fix?

Upgrade spree_api to version 3.7.13, 4.0.5, 4.1.12 or higher.

Overview

spree_api is a Spree Api module

Affected versions of this package are vulnerable to Information Exposure. An attacker can query the API v2 Order Status endpoint with an empty string passed as an Order token.

References