Cross-site Request Forgery (CSRF) Affecting spree_auth_devise Open this link in a new tab package, versions <4.0.1 >=4.1.0, <4.1.1 >=4.2.0, <4.2.1 >=4.3.0, <4.4.1


0.0
critical
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREEAUTHDEVISE-1922730

  • published

    18 Nov 2021

  • disclosed

    18 Nov 2021

  • credit

    Marc Busqué

How to fix?

Upgrade spree_auth_devise to version 4.0.1, 4.1.1, 4.2.1, 4.4.1 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via spree_auth_devise.

Note: The package is affected only if protect_from_forgery method is both:

  1. Executed whether as:

    a) A before_action callback (the default) b) A prepend_before_action (option prepend: true given) before the :load_object hook in Spree::UserController (most likely order to find).

  2. Configured to use :null_session or :reset_session strategies (:null_session is the default in case the no strategy is given, but rails --new generated skeleton use :exception).

Meaning, that applications that haven't been configured differently from what it's generated with Rails aren't affected.

References