Json Hijacking Affecting spree_backend Open this link in a new tab package, versions <3.0.7 ,>=2.2.0


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREEBACKEND-20475

  • published

    10 Jan 2018

  • disclosed

    22 Mar 2016

  • credit

    John Hawthorn

Introduced: 22 Mar 2016

CWE-642 Open this link in a new tab

How to fix?

Upgrade spree_backend to version 3.0.7 or higher.

Overview

spree_backend is Required dependency for Spree.

Affected versions of the package are vulnerable to Json Hijacking, due to returning a top level array, making the JSON interpreted as valid javascript.