Json Hijacking Affecting spree_frontend package, versions <3.0.7, >=3.0.0.rc1


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREEFRONTEND-20477

  • published

    10 Jan 2018

  • disclosed

    22 Feb 2016

  • credit

    John Hawthorn

How to fix?

Upgrade spree_frontend to version 3.0.7 or higher.

Overview

spree_frontend is Frontend e-commerce functionality for the Spree project.

Affected versions of the package are vulnerable to Json Hijacking, due to returning a top level array, making the JSON interpreted as valid javascript.