Access Restriction Bypass Affecting sqlite3-ruby Open this link in a new tab package, versions <1.2.4


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SQLITE3RUBY-536098

  • published

    28 Nov 2019

  • disclosed

    13 May 2011

  • credit

    Unknown

How to fix?

Upgrade sqlite3-ruby to version 1.2.4 or higher.

Overview

sqlite3-ruby is a module to interface with the SQLite3 database engine.

Affected versions of this package are vulnerable to Access Restriction Bypass. It uses weak permissions for unspecified files, which allows local users to gain privileges via unknown vectors.