Cross-site Request Forgery (CSRF) Affecting trestle-auth Open this link in a new tab package, versions >=0.4.0, <0.4.2


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-TRESTLEAUTH-1245466

  • published

    14 Apr 2021

  • disclosed

    14 Apr 2021

  • credit

    Tomek Rabczak

How to fix?

Upgrade trestle-auth to version 0.4.2 or higher.

Overview

trestle-auth is an authentication plugin for the Trestle admin framework.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). An attacker can create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials.

References