Improper Certificate Validation Affecting tweetstream package, versions >=0.0.0


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-TWEETSTREAM-1245514

  • published

    14 Apr 2021

  • disclosed

    13 Apr 2021

  • credit

    Unknown

How to fix?

There is no fixed version for tweetstream.

Overview

Affected versions of this package are vulnerable to Improper Certificate Validation. TLS hostname is not validated sufficiently.