HTTP Request Smuggling Affecting webrick Open this link in a new tab package, versions <1.5.1 >=1.6.0, <1.6.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-WEBRICK-1013845

  • published

    29 Sep 2020

  • disclosed

    29 Sep 2020

  • credit

    Unknown

How to fix?

Upgrade webrick to version 1.5.1, 1.6.1 or higher.

Overview

webrick is a HTTP server toolkit that can be configured as an HTTPS server, a proxy server, and a virtual-host server.

Affected versions of this package are vulnerable to HTTP Request Smuggling. It was too tolerant against an invalid Transfer-Encoding header. This may lead to inconsistent interpretation between WEBrick and some HTTP proxy servers, which may allow the attacker to "smuggle" a request.

References