Allocation of Resources Without Limits or Throttling Affecting apache/avro package, versions <0.14.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-APACHEAVRO-2977084
  • published 9 Aug 2022
  • disclosed 9 Aug 2022
  • credit Evan Richter at ForAllSecure

How to fix?

Upgrade apache/avro to version 0.14.0 or higher.

Overview

apache/avro is a library for working with Apache Avro in Rust language.

Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling due to the possibility for a Reader to consume memory beyond the allowed constraints.

Note:

The Avro-rs package has migrated to the Apache Avro package, it is recommended to use Apache Avro instead, as it addresses this issue.