Improper Verification of Cryptographic Signature Affecting biscuit-auth package, versions <2.0.0


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-BISCUITAUTH-2869621
  • published 14 Jun 2022
  • disclosed 14 Jun 2022
  • credit Goichiro Hanaoka, Kazuo Ohta, Yusuke Sakai, Bagus Santoso, Kaoru Takemure, and Yunlei Zhao

How to fix?

Upgrade biscuit-auth to version 2.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature which can allow an attacker to create a token with any access level. This is due to a way to forge valid Γ-signatures, an algorithm that is used in the Biscuit specification version 1.