Buffer Overflow Affecting crossbeam package, versions <0.4.4


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-CROSSBEAM-1019357
  • published 18 Oct 2020
  • disclosed 18 Oct 2020
  • credit Unknown

How to fix?

Upgrade crossbeam to version 0.4.4 or higher.

Overview

crossbeam is a package that provides a set of tools for concurrent programming.

Affected versions of this package are vulnerable to Buffer Overflow. It causes deallocation with the incorrect capacity when Vec::from_iter has allocated different sizes with the number of iterator elements.