Privilege Escalation Affecting deno package, versions >=1.5.0 <1.10.2



    Attack Complexity Low
    User Interaction Required
    Confidentiality High
Expand this section
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-DENO-1298032
  • published 30 May 2021
  • disclosed 30 May 2021
  • credit Nayeem Rahman

How to fix?

Upgrade deno to version 1.10.2 or higher.


deno is an a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust.

Affected versions of this package are vulnerable to Privilege Escalation. Modules that are dynamically imported using import() or new Worker are able to bypass file system permission checks when importing other modules.