Out-of-bounds Write Affecting deno package, versions >=1.32.0 <1.32.1


Severity

Recommended
0.0
high
0
10

    Threat Intelligence

    EPSS
    0.14% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-DENO-3370259
  • published 24 Mar 2023
  • disclosed 23 Mar 2023
  • credit lucacasonato

How to fix?

Upgrade deno to version 1.32.1 or higher.

Overview

deno is an a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust.

Affected versions of this package are vulnerable to Out-of-bounds Write due to improperly handling resizable ArrayBuffer, when passing Resizable ArrayBuffers to asynchronous native functions that are shrunk during the asynchronous operation.

Note: Deno Deploy users are not affected.

The problem has been temporarily resolved by disabling resizable ArrayBuffers in Deno 1.32.1.

Workaround

Users who are unable to upgrade to the fixed version can run with --v8-flags=--no-harmony-rab-gsab to disable resizable ArrayBuffers.

CVSS Scores

version 3.1
Expand this section

Snyk

7.3 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    Low
Expand this section

NVD

9.8 critical