Improper Privilege Management Affecting deno package, versions >=1.34.0 <1.34.1


Severity

Recommended
0.0
high
0
10

    Threat Intelligence

    EPSS
    0.24% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-DENO-5663555
  • published 1 Jun 2023
  • disclosed 31 May 2023
  • credit sylc

How to fix?

Upgrade deno to version 1.34.1 or higher.

Overview

deno is an a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust.

Affected versions of this package are vulnerable to Improper Privilege Management when outbound HTTP requests made using the built-in node:http or node:https modules are incorrectly not checked against the network permission allow list (--allow-net).

CVSS Scores

version 3.1
Expand this section

Snyk

7.2 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Changed
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    None
Expand this section

NVD

9.8 critical