Improper Authorization Affecting deno package, versions <1.43.1


Severity

Recommended
0.0
high
0
10

    Threat Intelligence

    Exploit Maturity
    Proof of concept
    EPSS
    0.04% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-DENO-6814539
  • published 8 May 2024
  • disclosed 7 May 2024
  • credit Cristian-Alexandru STAICU

How to fix?

Upgrade deno to version 1.43.1 or higher.

Overview

deno is an a simple, modern and secure runtime for JavaScript and TypeScript that uses V8 and is built in Rust.

Affected versions of this package are vulnerable to Improper Authorization due to improper handling of file-system operations on privileged files. An attacker can escalate permissions and access or modify system-level files by exploiting the lack of explicit deny flags in command-line arguments.

References

CVSS Scores

version 3.1
Expand this section

Snyk

8.4 high
  • Attack Vector (AV)
    Adjacent
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    High
  • User Interaction (UI)
    None
  • Scope (S)
    Changed
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High