Race Condition Affecting futures-util package, versions >=0.3.2 <0.3.7


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUST-FUTURESUTIL-1290575
  • published10 May 2021
  • disclosed22 Oct 2020
  • creditQwaz

Introduced: 22 Oct 2020

CVE-2020-35905  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade futures-util to version 0.3.7 or higher.

Overview

futures-util is a Common utilities and extension traits for the futures-rs library.

Affected versions of this package are vulnerable to Race Condition due to improper Send/Sync implementation for MappedMutexGuard.

CVSS Base Scores

version 3.1