Denial of Service (DoS) Affecting futures-util package, versions >=0.3.0 <0.3.2


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-FUTURESUTIL-2929005
  • published 17 Jun 2022
  • disclosed 24 May 2022
  • credit okready

How to fix?

Upgrade futures-util to version 0.3.2 or higher.

Overview

futures-util is a Common utilities and extension traits for the futures-rs library.

Affected versions of this package are vulnerable to Denial of Service (DoS) due to improper handling of Sync on FuturesUnordered.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package