Double Free Affecting qwutils package, versions <0.3.1


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-QWUTILS-2929008
  • published 17 Jun 2022
  • disclosed 24 May 2022
  • credit Unknown

How to fix?

Upgrade qwutils to version 0.3.1 or higher.

Overview

Affected versions of this package are vulnerable to Double Free. When a Clone panic occurs, insert_slice_clone can perform a double drop.