Information Exposure Affecting rustls package, versions >=0.23.13 <0.23.45


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUST-RUSTLS-20883247
  • published13 Oct 2026
  • disclosed5 Oct 2026
  • creditUnknown

Introduced: 5 Oct 2026

New CVE NOT AVAILABLE CWE-200  (opens in a new tab)

How to fix?

Upgrade rustls to version 0.23.45 or higher.

Overview

rustls is a modern TLS library in Rust.

Affected versions of this package are vulnerable to Information Exposure in the processing of TLS 1.3 handshake messages across encryption level boundaries. An attacker can cause plaintext handshake messages to be accepted when they should be encrypted by injecting such messages in the same record as a key-changing message.

CVSS Base Scores

version 4.0
version 3.1