Buffer Overflow Affecting smallvec package, versions >=0.6.3 <0.6.14 >=1.0.0 <1.6.1


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity High
    Availability High
Expand this section
SUSE
7.4 high
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUST-SMALLVEC-2929009
  • published 17 Jun 2022
  • disclosed 24 May 2022
  • credit Yechan Bae

How to fix?

Upgrade smallvec to version 0.6.14, 1.6.1 or higher.

Overview

smallvec is a "Small vector" optimization for Rust: store up to a small number of items on the stack.

Affected versions of this package are vulnerable to Buffer Overflow in SmallVec::insert_many. Exploiting this vulnerability is possible only if the iterator passed to insert_many yielded more items than the lower bound returned from its size_hint method.