Improper Input Validation Affecting wasmtime package, versions >=39.0.0 <48.0.4>=49.0.0 <49.0.2


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Input Validation vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-RUST-WASMTIME-21708533
  • published25 Oct 2026
  • disclosed22 Oct 2026
  • creditUnknown

Introduced: 22 Oct 2026

NewCVE-2026-115384  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade wasmtime to version 48.0.4, 49.0.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation via unvalidated async callback result types. An attacker can overwrite return addresses and potentially crash the host or escape the sandbox by supplying components with mistyped component-model-async callback functions.

References

CVSS Base Scores

version 4.0
version 3.1