Improper Validation of Specified Quantity in Input Affecting wasmtime-wasi-http package, versions >=46.0.0 <48.0.4>=49.0.0 <49.0.2


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.28% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUST-WASMTIMEWASIHTTP-21708420
  • published25 Oct 2026
  • disclosed22 Oct 2026
  • creditUnknown

Introduced: 22 Oct 2026

NewCVE-2026-115382  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade wasmtime-wasi-http to version 48.0.4, 49.0.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Validation of Specified Quantity in Input via the wasi:http process. An attacker can cause the host to crash by specifying a zero between-bytes-timeout request option, which is forwarded to a Tokio API that panics.

References

CVSS Base Scores

version 4.0
version 3.1