Directory Traversal Affecting accountsservice package, versions <0.6.45-6.7.6


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.05% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-ACCOUNTSSERVICE-2759675
  • published14 Apr 2022
  • disclosed5 Nov 2018

Introduced: 5 Nov 2018

CVE-2018-14036  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 accountsservice to version 0.6.45-6.7.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream accountsservice package and not the accountsservice package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

Directory Traversal with ../ sequences occurs in AccountsService before 0.6.50 because of an insufficient path check in user_change_icon_file_authorized_cb() in user.c.