CVE-2018-11797 Affecting apache-pdfbox package, versions <1.8.12-5.6.3


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
3.51% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-APACHEPDFBOX-2760919
  • published14 Apr 2022
  • disclosed13 Nov 2018

Introduced: 13 Nov 2018

CVE-2018-11797  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 apache-pdfbox to version 1.8.12-5.6.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apache-pdfbox package and not the apache-pdfbox package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In Apache PDFBox 1.8.0 to 1.8.15 and 2.0.0RC1 to 2.0.11, a carefully crafted PDF file can trigger an extremely long running computation when parsing the page tree.

CVSS Base Scores

version 3.1