Out-of-bounds Write Affecting audiofile-devel package, versions <0.3.6-3.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
4.65% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-AUDIOFILEDEVEL-2757904
  • published14 Apr 2022
  • disclosed26 Oct 2018

Introduced: 26 Oct 2018

CVE-2018-17095  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 audiofile-devel to version 0.3.6-3.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream audiofile-devel package and not the audiofile-devel package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

An issue has been discovered in mpruett Audio File Library (aka audiofile) 0.3.6, 0.3.5, 0.3.4, 0.3.3, 0.3.2, 0.3.1, 0.3.0. A heap-based buffer overflow in Expand3To4Module::run has occurred when running sfconvert.

CVSS Base Scores

version 3.1