Weak Password Requirements Affecting cloud-init-config-suse package, versions <19.4-5.24.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES150-CLOUDINITCONFIGSUSE-2715608
  • published14 Apr 2022
  • disclosed4 Mar 2020

Introduced: 4 Mar 2020

CVE-2020-8632  (opens in a new tab)
CWE-521  (opens in a new tab)

How to fix?

Upgrade SLES:15.0 cloud-init-config-suse to version 19.4-5.24.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cloud-init-config-suse package and not the cloud-init-config-suse package as distributed by SLES. See How to fix? for SLES:15.0 relevant fixed versions and status.

In cloud-init through 19.4, rand_user_password in cloudinit/config/cc_set_passwords.py has a small default pwlen value, which makes it easier for attackers to guess passwords.

CVSS Base Scores

version 3.1